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Photoshop Postproduction Techniques 

Do not expect that output from any renderer will automatically be good enough 
to print or display.   All output can be improved (and in many cases rescued) by 
postproduction in Photoshop. 

Typical Problems with Render Output that can be fixed in Post include: 

  Bad Color Balance 

  Too much noise 

  Too dark/Too light 

  Strange artifacts 

  Insufficient sharpness 

  Insufficient output resolution 

Photoshop is best approached systematically.  In other words, the most efficient 
and effective way to work in Photoshop is to adopt a consistent series of steps—a 
workflow—that you apply to every image before you bring it to print or to the 
screen. 

The aim of this lecture is to outline such a workflow in CS3.    Since my own 
workflow relies upon a number of proprietary actions and plugins that go beyond 
the scope of the tools easily available to you, I have drawn on Scott Kelby’s 7 
Point System for Photoshop (Peachpit Press, 2007).   This is a truly excellent book 
and I can recommend it highly.      

Before we begin, a word about layer masks.  Layer masks are channels that sit 
beside layers and control their visibility (or the visibility of their effects).  When 
layer masks are filled with black, they are opaque and block the effect of the 
adjustment layer entirely.  When layer masks are filled with white, they are totally 
transparent and do not affect the adjustment later at all.  In general, a good 



strategy for using layer masks is to start by filling the layer mask with black.   By 
using a soft brush and “painting” in the mask area with white, you selectively 
bring back in the layer effect in the areas where you want it to be.  It can be 
helpful to view the mask on the image itself by hitting forward slash.  It can also 
be useful to invert the mask with ctrl‐I. 

Understanding and using layer masks is a crucial skill in Photoshop.   Master them 
and your imaging work will advance to a new level. 

 

Photoshop Postproduction Workflow 

1.  Process Image in Adobe Camera Raw 
2. Add Curve Adjustment Layer 
3. Correct Shadows and Highlights 
4. Dodge and Burn 
5. Optimize color with Channel Adjustments 
6. Optimize color with Layer Blend Modes and Masks 
7. Noise processing 
8. Sharpening 

 

Step 1‐‐Process Image in Adobe Camera Raw 

Whatever image format you are working with—JPEG, TIFF, or RAW—it is always 
best to begin by opening them in Adobe Camera Raw (ACR).  ACR is a separate 
plugin that runs outside of Photoshop itself.    

>File>Open As>Format>ACR 

Recommended Adjustments in ACR: 

Adjust color temperature to taste by moving temperature slider back and 
forth. 



Adjust exposure to taste by moving exposure slider back and forth.  Keep 
an eye on the highlight clipping warning triangle in the upper right hand 
corner.  It should be black.  If it turns any other color, you are losing detail 
in the highlights.  Click on the triangle to display what areas are being 
clipped in the image itself. 

If you are getting some clipping, you do not necessarily have to back off the 
exposure adjustment.  You can also recover the clipped highlights by 
moving the Recovery slider to the right.  The Recovery slider also does a 
nice job of darkening light skies. 

If the image feels washed out, give the blacks more punch by dragging the 
Blacks slider to the right until the color in the image looks appropriately 
saturated and balanced. 

Activate the Zoom tool and view pixels at 100 pct.  Drag the Clarity slider to 
the right to add contrast and sharpness to the midtones.  Watch the image 
carefully to be sure that you do not go too far.   You will rarely have to go 
over 50. 

Click on the Details icon (third from the left at the top of the panel area) to 
open up the Detail control panel.  Increase Detail Amount to about 65. 

  Open image in Photoshop by hitting the Open Image button. 

 

Step 2—Control Overall Contrast with Curve Adjustment Layers 

First,  I recommend resaving the image you are working on as 
image_name_working.tiff.  Although we always try to work non‐destructively, 
some destructive moves (such as flattening) are necessary, so it is good practice 
to preserve the original version of the image in separate file.    

Next, add a Curves adjustment layer.  A good place to start is by applying a 
“medium contrast” curve preset from the preset menu at the top of the dialogue 
box.    



The CS3 curve presets are generally good, and you should experiment with all of 
them.  Once you have established a good base, you can tweak the curves as you 
like to fine tune your results.   You can also apply a layer mask to paint over any 
areas that you do not want to have added contrast. 

[There is a slightly more advanced way to work with curves that I will mention in 
passing.  This method involves telling photoshop which specific RGB values to use 
for shadows, midtones, and highlights, and can be very effective in optimizing 
images for print.    Go to the Curves dialogue box and note that there are three 
Eyedropper tools beneath the curve grid.   From left to right, these Eyedroppers 
control the colors that are mapped to shadow, midtone, and highlight areas.  
Double click on each and enter the following values:  shadows RGB (7,7,7), 
midtones RGB (133,133,133), highlights RGB (245, 245,245).  Once you have 
accepted these values, they become part of your stored presets.  You can then 
use each Eyedropper to set the shadow, midtone, and highlight colors in you 
image.  Simply click on an Eyedropper (say shadow) and then click on the darkest 
black you can find in the image.  Do the same for midtones and highlights.  In this 
way, you basically remap image tonality to your taste.) 

Click  OK.  Go to the Layers Panel and choose “Flatten Image” from the panel’s 
flyout menu. 

 

Step 3—Control Shadow and Highlight with Smart Filters 

When you are working with colorful images, applying a normal Shadow/Highlight 
adjustment is usually not sufficient to open up dark shadow areas.  It will also 
increase color saturation, which may not be desirable.   

In order to get around these shortcomings, we can apply the Shadow/Highlight 
adjustment to the LAB Lightness channel, as follows:      

  Convert image to LAB mode.  Image>Mode>LAB 

  Go to the Channels panel and click on the Lightness channel. 



Duplicate the Background Layer (CTRL‐J), choose Convert for Smart Filters 
from the Filters menu, and choose Shadow/Highlight from the Image menu.   

Turn on the “Show More Options” checkbox.    Play with lowering the 
amount, increasing the Threshold, and increasing the radius to between 
250 and 300. 

The Smart Filter technique automatically adds a layer mask, which can be 
used to selectively apply the Shadow/ Highlight adjustment. 

  Click OK when you are satisfied and convert the image back to RGB mode.   

 

Step 4—Dodge and Burn (or “Painting with Light”) 

If there are areas of the image that you want to darken or lighten, do the 
following: 

  Add a Curves Adjustment Layer. 

  Add a point to the center of the curve. 

  Drag the curve up to make the image brighter and down to make it darker. 

Click on the layer mask and press ctrl‐I to invert it.  Paint in white with a 
soft brush on the layer mask to selectively apply the Curve Adjustment. 

 

Step 5—Color Enhancement with LAB 

In order to make the image colors “pop”,  try the following:   

Convert image to LAB mode.  Image>Mode>Lab 

  Go to Image Menu and choose Apply Image. 

When the Apply Image dialogue box pops up, change blend mode to Soft 
Light.   Experiment with three different looks by choosing “a”, “b”, or “lab” 



from the Channel rollout.  This is a matter of taste—there is no right 
answer.   

You can also control the intensity of this effect by lowering the opacity. 

When you are done, convert the image back to RGB mode.  

   

Step 6—Controlling Color Density and Contrast with Blending Modes 

 To control the overall tonal balance of the image, as well as making specific local 
adjustments such as lightening the subject or darkening the sky, try the following: 

  Duplicate the background layer.  Ctrl‐J 

Set blending mode to Screen (to make image lighter overall) or Multiply (to 
make it darker overall) 

Add a layer mask to the new layer, select it, and invert it (ctrl‐I). 

Paint on the mask in white to apply the effect as necessary.  

 

Step 7‐‐Sharpening 

It is generally best to sharpen after you have made all of your desired 
adjustments.  The suggested workflow is as follows: 

  Save your image. 

  Flatten it and rename it as image_output.tiff 

  Duplicate background layer. 

Apply the Unsharp Mask filter to the duplicated layer.  For general medium 
sharpening,  try Amount = 85%, Radius = 1.0, and Threshold = 4. 

Once you have sharpened, go to Fade Unsharp Mask, change the fade 
mode to luminosity, and fade the sharpening back.  This fade is important 



since it allows you to avoid the strange color halos that are produced by 
Unsharp Mask. 

   

 

Reducing Image Noise  

 

Image noise can appear in two forms: luminance (grayscale) noise, which makes 
an image look grainy or patchy, and color noise, which is usually visible as colored 
artifacts in the image.  

Luminance noise may be more pronounced in one channel of the image, usually 
the blue channel.  

You can adjust the noise for each channel separately in Advanced mode. Before 
opening the filter, examine each channel in your image separately to see if noise 
is prevalent in one channel. You preserve more image detail by correcting one 
channel rather than making an overall correction to all channels. 

 

To Reduce Image Noise, follow the following steps: 

Choose Filter > Noise > Reduce Noise.  

Zoom in on the preview image to get a better view of image noise.  

Set options:  

Strength:   Controls the amount of luminance noise reduction applied to all 
image channels.  

Preserve Details:  Preserves edges and image details such as hair or texture 
objects. A value of 100 preserves the most image detail, but reduces 
luminance noise the least. 



Balance the Strength and Preserve Details controls to fine tune noise 
reduction.  

Reduce Color Noise Removes random color pixels. A higher value reduces 
more color noise.  

Sharpen Details Sharpens the image. Removing noise reduces image 
sharpness. Use the sharpening control in the dialog box or use one of the 
other Photoshop sharpening filters later to restore sharpness.  

If luminance noise is more prevalent in one or two color channels, click the 
Advanced button and then choose the color channel from the Channel menu. Use 
the Strength and Preserve Details controls to reduce noise in that channel. 

There are commercially available plugins that may do a better job than the built in 
CS3 noise filter. 

NeatNoise and Noise Ninja are both worth investigating  

 

 

Increasing Image Resolution with Resampling 

Resampling is changing the amount of image data as you change either the pixel 
dimensions or the resolution of an image. When you downsample (decrease the 
number of pixels), information is deleted from the image. When you resample up 
(increase the number of pixels, or upsample), new pixels are added. You specify 
an interpolation method to determine how pixels are added or deleted. 

Keep in mind that resampling can result in poorer image quality. For example, 
when you resample an image to larger pixel dimensions, the image loses some 
detail and sharpness. 

 Photoshop resamples images using an interpolation method to assign color 
values to any new pixels based on the color values of existing pixels. You can 
choose which method to use in the Image Size dialog box. 



Bicubic Smoother is the best interpolation method for increasing image output 
resolution.  It is said that multiple “stairstep”  interpolations produce better 
results than single larger changes.  In other words, if you want to increase your 
image output resolution by 10 percent, it would be better to make 5 increases of 
2 percent than it would to make 1 large increase of 10 percent. 

At the end of the day, Bicubic Smoother is OK, but superior commercial solutions 
exist.  Genuine Fractals is the best resampler of which I am aware.  They offer a 
fully functional, limited period trial.  It is well worth checking out. 

 

 

 

 

 

 

 

 

   

    

 


